Kurz gesagt
- CVE-2017-1001003 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in mathjs (mathjs project), mathjs.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 77.1% aller Schwachstellen.
- Abhilfe: auf 3.17.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| mathjs | < 3.17.0
| 3.17.0
|
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object.
Recommendation
Upgrade to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free