Kurz gesagt
- CVE-2017-16014 ist eine Schwachstelle (HOCH (CVSS 7.5)) in http-proxy (http-proxy project), http-proxy.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 76.8% aller Schwachstellen.
- Abhilfe: auf 0.7.0 oder neuer aktualisieren.
Description
Affected versions of http-proxy are vulnerable to a denial of service attack, wherein an attacker can force an error which will cause the server to crash.
Recommendation
Update to version 0.7.0 or later.
NVD description
Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free