Kurz gesagt
- CVE-2017-16023 ist eine Schwachstelle (HOCH (CVSS 7.5)) in decamelize (decamelize project), decamelize.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.4%, höher als bei 73.2% aller Schwachstellen.
- Abhilfe: auf 1.1.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| decamelize | = 1.1.0= 1.1.1
| No fix yet |
| decamelize npm | ≥ 1.1.0, < 1.1.2
| 1.1.2
|
Description
Affected versions of decamelize are susceptible to a denial of service vulnerability when user input is passed directly into decamelize.
Recommendation
Update to version 1.1.2 or later.
NVD description
Decamelize is used to convert a dash/dot/underscore/space separated string to camelCase. Decamelize 1.1.0 through 1.1.1 uses regular expressions to evaluate a string and takes unescaped separator values, which can be used to create a denial of service attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free