Kurz gesagt
- CVE-2017-16025 ist eine Schwachstelle (MITTEL (CVSS 5.9)) in nes (hapijs), nes.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.9%, höher als bei 79.4% aller Schwachstellen.
- Abhilfe: auf 6.4.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| nes | ≤ 6.4.0
| No fix yet |
| nes npm | < 6.4.1
| 6.4.1
|
Description
Affected versions of nes are vulnerable to denial of service when given an invalid cookie header, and websocket authentication is set to cookie. Submitting an invalid cookie on the websocket upgrade request will cause the node process to throw and exit.
Recommendation
Update to version 6.4.1 or later.
NVD description
Nes is a websocket extension library for hapi. Hapi is a webserver framework. Versions below and including 6.4.0 have a denial of service vulnerability via an invalid Cookie header. This is only present when websocket authentication is set to `cookie`. Submitting an invalid cookie on the websocket upgrade request will cause the node process to error out.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free