Kurz gesagt
- CVE-2017-16029 ist eine Schwachstelle (HOCH (CVSS 7.5)) in hostr (hostr project), hostr.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.8%, höher als bei 78.6% aller Schwachstellen.
- Abhilfe: auf 2.3.6 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| hostr | ≤ 2.3.5
| No fix yet |
| hostr npm | < 2.3.6
| 2.3.6
|
Description
Affected versions of hostr are vulnerable to directory traversal which allows attackers to read files outside the current directory by sending ../ in the url path for GET requests.
Recommendation
Upgrade to version 2.3.6 or later.
NVD description
hostr is a simple web server that serves up the contents of the current directory. There is a directory traversal vulnerability in hostr 2.3.5 and earlier that allows an attacker to read files outside the current directory by sending `../` in the url path for GET requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free