Kurz gesagt
- CVE-2017-16031 ist eine Schwachstelle (HOCH (CVSS 7.5)) in socket.io (socket), socket.io.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.0%, höher als bei 80.4% aller Schwachstellen.
- Abhilfe: auf 0.9.7 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| socket.io | ≤ 0.9.6
| No fix yet |
| socket.io npm | < 0.9.7
| 0.9.7
|
Description
Affected versions of socket.io depend on Math.random() to create socket IDs, and therefore the IDs are predictable. With enough information on prior IDs, an attacker may be able to guess the socket ID and gain access to socket.io servers without authorization.
Recommendation
Update to v0.9.7 or later.
NVD description
Socket.io is a realtime application framework that provides communication via websockets. Because socket.io 0.9.6 and earlier depends on `Math.random()` to create socket IDs, the IDs are predictable. An attacker is able to guess the socket ID and gain access to socket.io servers, potentially obtaining sensitive information.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free