Kurz gesagt
- CVE-2017-16042 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in growl (growl project), growl.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 4.6%, höher als bei 91.7% aller Schwachstellen.
- Abhilfe: auf 1.10.2, 1.10.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| growl | < 1.10.2
| 1.10.2
|
| growl npm | < 1.10.0
| 1.10.0
|
Description
Affected versions of growl do not properly sanitize input prior to passing it into a shell command, allowing for arbitrary command execution.
Recommendation
Update to version 1.10.0 or later.
NVD description
Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free