Kurz gesagt
- CVE-2017-16043 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in shout (shout project), shout.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.00%, höher als bei 63.0% aller Schwachstellen.
- Abhilfe: auf 0.50.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| shout | ≥ 0.44.0, < 0.50.0
| 0.50.0
|
| shout npm | ≥ 0.44.0, < 0.50.0
| 0.50.0
|
Description
Affected versions of shout do not escape the /topic command in messages, and are therefore vulnerable to cross-site scripting.
Recommendation
Update to version 0.50.0 or later.
NVD description
Shout is an IRC client. Because the `/topic` command in messages is unescaped, attackers have the ability to inject HTML scripts that will run in the victim's browser. Affects shout >=0.44.0 <=0.49.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free