Kurz gesagt
- CVE-2017-16099 ist eine Schwachstelle (HOCH (CVSS 7.5)) in no-case (no-case project), no-case.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.6%, höher als bei 75.4% aller Schwachstellen.
- Abhilfe: auf 2.3.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| no-case | < 2.3.2
| 2.3.2
|
| no-case npm | < 2.3.2
| 2.3.2
|
Description
Affected versions of no-case are vulnerable to a regular expression denial of service when parsing untrusted user input.
Recommendation
Update to version 2.3.2 or later.
NVD description
The no-case module is vulnerable to regular expression denial of service. When malicious untrusted user input is passed into no-case it can block the event loop causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free