Kurz gesagt
- CVE-2017-16111 ist eine Schwachstelle (HOCH (CVSS 7.5)) in content (content project), content.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.1%, höher als bei 65.9% aller Schwachstellen.
- Abhilfe: auf 3.0.7 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| content | ≤ 3.0.5
| No fix yet |
| content npm | < 3.0.7
| 3.0.7
|
Description
Affected versions of content are vulnerable to a regular expression denial of service when parsing malicious Content-Type and Content-Disposition headers.
Recommendation
Update to version 3.0.6 or later.
NVD description
The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free