Kurz gesagt
- CVE-2017-16114 ist eine Schwachstelle (HOCH (CVSS 7.5)) in marked (marked project), marked.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 77.6% aller Schwachstellen.
- Abhilfe: auf 0.3.9 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| marked | < 0.3.9
| 0.3.9
|
| marked npm | < 0.3.9
| 0.3.9
|
Description
Affected versions of marked are vulnerable to a regular expression denial of service.
The amplification in this vulnerability is significant, with 1,000 characters resulting in the event loop being blocked for around 6 seconds.
Recommendation
Update to version 0.3.9 or later.
NVD description
The marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free