Kurz gesagt
- CVE-2017-16117 ist eine Schwachstelle (HOCH (CVSS 7.5)) in slug (slug project), slug.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.6%, höher als bei 75.4% aller Schwachstellen.
- Abhilfe: auf 0.9.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| slug | ≤ 0.9.1
| No fix yet |
| slug npm | < 0.9.2
| 0.9.2
|
Description
Affected versions of slug are vulnerable to a regular expression denial of service when parsing untrusted user input.
The issue is low severity, as it takes 50,000 characters to cause the event loop to block for 2 seconds,
About 50k characters can block the event loop for 2 seconds.
Recommendation
Update to version 0.9.2 or later.
NVD description
slug is a module to slugify strings, even if they contain unicode. slug is vulnerable to regular expression denial of service is specially crafted untrusted input is passed as input. About 50k characters can block the event loop for 2 seconds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free