Kurz gesagt
- CVE-2017-16136 ist eine Schwachstelle (HOCH (CVSS 7.5)) in method-override (expressjs), method-override.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.2%, höher als bei 68.1% aller Schwachstellen.
- Abhilfe: auf 2.3.10 oder neuer aktualisieren.
Description
Affected versions of method-override are vulnerable to a regular expression denial of service vulnerability when untrusted user input is passed into the X-HTTP-Method-Override header.
Recommendation
Update to version 2.3.10 or later
NVD description
method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free