Kurz gesagt
- CVE-2017-7235 ist eine Schwachstelle (HOCH (CVSS 8.8)) in cfscrape, cloudflare-scrape (cloudflare-scrape project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.5%, höher als bei 75.2% aller Schwachstellen.
- Abhilfe: auf 1.8.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| cfscrape PyPI | ≥ 1.6.6, < 1.8.0
| 1.8.0
|
| cloudflare-scrape | = 1.6.6= 1.6.7= 1.6.8= 1.7.0= 1.7.1
| No fix yet |
Description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
NVD description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free