| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.struts:struts2-core | ≥ 2.5.0, < 2.5.12 | 2.5.12 |
| struts | = 2.5= 2.5.1= 2.5.10= 2.5.10.1= 2.5.2= 2.5.5= 2.5.8 |
If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free