| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.struts:struts2-core | ≥ 2.3.7, < 2.3.33≥ 2.5.0, < 2.5.12 | 2.3.332.5.12 |
| struts | = 2.3.10= 2.3.11= 2.3.12= 2.3.13= 2.3.14= 2.3.14.1= 2.3.14.2= 2.3.14.3= 2.3.15= 2.3.15.1= 2.3.15.2= 2.3.15.3= 2.3.16= 2.3.16.1= 2.3.16.2= 2.3.16.3= 2.3.17= 2.3.19= 2.3.20= 2.3.20.1= 2.3.20.2= 2.3.20.3= 2.3.21= 2.3.22= 2.3.23= 2.3.24= 2.3.24.1= 2.3.24.2= 2.3.24.3= 2.3.25= 2.3.26= 2.3.27= 2.3.28= 2.3.28.1= 2.3.29= 2.3.30= 2.3.31= 2.3.32= 2.3.7= 2.3.8= 2.3.9= 2.5= 2.5.1= 2.5.10= 2.5.10.1= 2.5.2= 2.5.3= 2.5.4= 2.5.5= 2.5.6= 2.5.7= 2.5.8= 2.5.9 |
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free