Kurz gesagt
- CVE-2017-9803 ist eine Schwachstelle (HOCH (CVSS 7.5)) in org.apache.solr:solr-core, solr (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.2%, höher als bei 82.5% aller Schwachstellen.
- Abhilfe: auf 6.6.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| org.apache.solr:solr-core Maven | ≥ 6.2.0, < 6.6.1
| 6.6.1
|
| solr | = 6.2.0= 6.2.1= 6.3.0= 6.4.0= 6.4.1= 6.4.2= 6.5.0= 6.5.1= 6.6.0
| No fix yet |
Description
Apache Solr's Kerberos plugin can be configured to use delegation tokens, which allows an application to reuse the authentication of an end-user or another application. There are two issues with this functionality (when using SecurityAwareZkACLProvider type of ACL provider e.g. SaslZkACLProvider). Firstly, access to the security configuration can be leaked to users other than the solr super user. Secondly, malicious users can exploit this leaked configuration for privilege escalation to further expose/modify private data and/or disrupt operations in the Solr cluster. The vulnerability is fixed from Apache Solr 6.6.1 onwards.
NVD description
Apache Solr's Kerberos plugin can be configured to use delegation tokens, which allows an application to reuse the authentication of an end-user or another application. There are two issues with this functionality (when using SecurityAwareZkACLProvider type of ACL provider e.g. SaslZkACLProvider). Firstly, access to the security configuration can be leaked to users other than the solr super user. Secondly, malicious users can exploit this leaked configuration for privilege escalation to further expose/modify private data and/or disrupt operations in the Solr cluster. The vulnerability is fixed from Apache Solr 6.6.1 onwards.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free