Kurz gesagt
- CVE-2018-1000060 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in sensu, sensu core (sensu).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.4%, höher als bei 83.8% aller Schwachstellen.
- Abhilfe: auf 1.2.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| sensu RubyGems | < 1.2.1
| 1.2.1
|
| sensu core | < 1.2.1
| 1.2.1
|
Description
The sensu rubygem prior to version 1.2.0 contains a CWE-522 (Insufficiently Protected Credentials) flaw that can result in sensitive configuration data (e.g. passwords) being logged in clear-text.
Users are advised to upgrade to rubygem version 1.2.1 or later.
NVD description
Sensu, Inc. Sensu Core version Before 1.2.0 & before commit 46ff10023e8cbf1b6978838f47c51b20b98fe30b contains a CWE-522 vulnerability in Sensu::Utilities.redact_sensitive() that can result in sensitive configuration data (e.g. passwords) may be logged in clear-text. This attack appear to be exploitable via victims with configuration matching a specific pattern will observe sensitive data outputted in their service log files. This vulnerability appears to have been fixed in 1.2.1 and later, after commit 46ff10023e8cbf1b6978838f47c51b20b98fe30b.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free