| Package | Affected versions | Patched versions |
|---|---|---|
| curl | ≥ 7.54.1, ≤ 7.59.0 |
curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free