Kurz gesagt
- CVE-2018-1109 ist eine Schwachstelle (MITTEL (CVSS 5.3)) in braces (braces project), braces.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.4%, höher als bei 72.4% aller Schwachstellen.
- Abhilfe: auf 2.3.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| braces | < 2.3.1
| 2.3.1
|
| braces npm | ≥ 2.2.0, < 2.3.1
| 2.3.1
|
Description
A vulnerability was found in Braces versions from v2.2.0 up to but not including v2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks. This has been patched in version 2.3.1.
NVD description
A vulnerability was found in Braces versions 2.2.0 and above, prior to 2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free