Kurz gesagt
- CVE-2018-25031 ist eine Schwachstelle (MITTEL (CVSS 4.3)) in org.webjars:swagger-ui, swagger ui (smartbear), swagger-ui.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 42.3%, höher als bei 98.7% aller Schwachstellen.
- Abhilfe: auf 4.1.3 oder neuer aktualisieren.
Description
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
NVD description
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free