Kurz gesagt
- CVE-2018-3711 ist eine Schwachstelle (HOCH (CVSS 7.5)) in fastify (fastify), fastify.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.8%, höher als bei 78.1% aller Schwachstellen.
- Abhilfe: auf 0.38.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| fastify | < 0.38.0
| 0.38.0
|
| fastify npm | < 0.38.0
| 0.38.0
|
Description
Affected versions of fastify are vulnerable to a denial of service when processing a request with Content-Type set to application/json and a very large payload.
Recommendation
Update to version 0.38.0 or later.
NVD description
Fastify node module before 0.38.0 is vulnerable to a denial-of-service attack by sending a request with "Content-Type: application/json" and a very large payload.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free