Kurz gesagt
- CVE-2018-3715 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in glance (glance project), glance.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.5%, höher als bei 73.6% aller Schwachstellen.
- Abhilfe: auf 3.0.4 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| glance | < 3.0.4
| 3.0.4
|
| glance npm | < 3.0.4
| 3.0.4
|
Description
Versions of glance before 3.0.4 are vulnerable to a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Recommendation
Update to version 3.0.4 or later.
NVD description
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free