Kurz gesagt
- CVE-2018-3745 ist eine Schwachstelle (KRITISCH (CVSS 9.1)) in atob (atob project), atob.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.1%, höher als bei 82.1% aller Schwachstellen.
- Abhilfe: auf 2.1.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| atob | ≤ 2.0.3
| No fix yet |
| atob npm | < 2.1.0
| 2.1.0
|
Description
Versions of atob before 2.1.0 uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Recommendation
Update to version 2.1.0 or later.
NVD description
atob 2.0.3 and earlier allocates uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free