Kurz gesagt
- CVE-2018-3750 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in deep extend (deep extend project), deep-extend.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.1%, höher als bei 82.2% aller Schwachstellen.
- Abhilfe: auf 0.5.1 oder neuer aktualisieren.
Description
Versions of deep-extend before 0.5.1 are vulnerable to prototype pollution.
Recommendation
Update to version 0.5.1 or later.
NVD description
The utilities function in all versions <= 0.5.0 of the deep-extend node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free