Kurz gesagt
- CVE-2018-3752 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in merge-options (merge-options project), merge-options.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.4%, höher als bei 73.1% aller Schwachstellen.
- Abhilfe: auf 1.0.1 oder neuer aktualisieren.
Description
All versions of merge-options are vulnerable to Prototype Pollution
Recommendation
Update to version 1.0.1 or greater.
NVD description
The utilities function in all versions <= 1.0.0 of the merge-options node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free