Kurz gesagt
- CVE-2018-3767 ist eine Schwachstelle (KRITISCH (CVSS 9.1)) in memjs (memcachier), memjs.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.5%, höher als bei 73.6% aller Schwachstellen.
- Noch keine gepatchte Version bekannt: Herstellerhinweise unter Referenzen verfolgen.
| Package | Affected versions | Patched versions |
|---|
| memjs | ≤ 1.1.0
| No fix yet |
| memjs npm | ≤ 1.2.0
| No fix yet |
Description
Versions of memjs prior to 1.2.2 are vulnerable to Denial of Service (DoS). The package fails to sanitize the value option passed to the Buffer constructor, which may allow attackers to pass large values exhausting system resources.
Recommendation
Upgrade to version 1.2.2 or later.
NVD description
`memjs` versions <= 1.1.0 allocates and stores buffers on typed input, resulting in DoS and uninitialized memory usage.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free