Kurz gesagt
- CVE-2018-3774 ist eine Schwachstelle (KRITISCH (CVSS 10.0)) in url-parse.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 3.8%, höher als bei 90.0% aller Schwachstellen.
- Abhilfe: auf 1.4.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| url-parse npm | ≥ 1.0.0, < 1.4.3
| 1.4.3
|
Description
Versions of url-parse before 1.4.3 returns the wrong hostname which could lead to Open Redirect, Server Side Request Forgery (SSRF), or Bypass Authentication Protocol vulnerabilities.
Recommendation
Update to version 1.4.3 or later.
NVD description
Incorrect parsing in url-parse <1.4.3 returns wrong hostname which leads to multiple vulnerabilities such as SSRF, Open Redirect, Bypass Authentication Protocol.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free