Kurz gesagt
- CVE-2018-3809 ist eine Schwachstelle (MITTEL (CVSS 5.3)) in serve (zeit), serve.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.0%, höher als bei 63.8% aller Schwachstellen.
- Abhilfe: auf 7.0.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| serve | = 6.5.3
| No fix yet |
| serve npm | < 7.0.0
| 7.0.0
|
Description
Versions of serve before 7.0.0 are vulnerable to information exposure, bypassing the ignore security control, but only on case insensitive file systems.
Recommendation
Update to version 7.0.0 or later.
NVD description
Information exposure through directory listings in serve 6.5.3 allows directory listing and file access even when they have been set to be ignored.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free