Kurz gesagt
- CVE-2019-1000007 ist eine Schwachstelle (HOCH (CVSS 7.4)) in aioxmpp, aioxmpp (aioxmpp project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.2%, höher als bei 67.6% aller Schwachstellen.
- Abhilfe: auf 0.10.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| aioxmpp PyPI | < 0.10.3
| 0.10.3
|
| aioxmpp | ≤ 0.10.2
| No fix yet |
Description
Impact
Possible remote Denial of Service or Data Injection.
Patches
Patches are available in https://github.com/horazont/aioxmpp/pull/268. They have been backported to the 0.10 release series and 0.10.3 is the first release to contain the fix.
Workarounds
To make the bug exploitable, an error suppressing xso_error_handler is required. By not using xso_error_handlers or not using the suppression function, the vulnerability can be mitigated completely (to our knowledge).
References
The pull request contains a detailed description: https://github.com/horazont/aioxmpp/pull/268
For more information
If you have any questions or comments about this advisory:
NVD description
aioxmpp version 0.10.2 and earlier contains a Improper Handling of Structural Elements vulnerability in Stanza Parser, rollback during error processing, aioxmpp.xso.model.guard function that can result in Denial of Service, Other. This attack appears to be exploitable via Remote. A crafted stanza can be sent to an application which uses the vulnerable components to either inject data in a different context or cause the application to reconnect (potentially losing data). This vulnerability appears to have been fixed in 0.10.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free