Kurz gesagt
- CVE-2019-10432 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in org.jenkins-ci.plugins:htmlpublisher, html publisher (jenkins).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.2%, höher als bei 67.6% aller Schwachstellen.
- Abhilfe: auf 1.21 oder neuer aktualisieren.
Description
Jenkins HTML Publisher Plugin prior to version 1.21 did not escape the project and build display names in the HTML report frame, resulting in a cross-site scripting vulnerability exploitable by users able to change those. This issue has been patched in version 1.21
NVD description
Jenkins HTML Publisher Plugin 1.20 and earlier did not escape the project and build display names in the HTML report frame, resulting in a cross-site scripting vulnerability exploitable by users able to change those.
Weitere Schwachstellen in org.jenkins-ci.plugins:htmlpublisher
Alle anzeigen →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free