| Package | Affected versions | Patched versions |
|---|---|---|
| mediawiki/core | ≥ 1.27.0, < 1.27.6≥ 1.30.0, < 1.30.2≥ 1.31.0, < 1.31.2 | 1.27.61.30.21.31.2 |
| mediawiki | ≥ 1.30.0, < 1.30.2≥ 1.31.0, < 1.31.2≥ 1.32.0, < 1.32.2 | 1.30.21.31.21.32.2 |
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free