Kurz gesagt
- CVE-2019-13173 ist eine Schwachstelle (HOCH (CVSS 7.5)) in fstream (fstream project), fstream.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.4%, höher als bei 84.2% aller Schwachstellen.
- Abhilfe: auf 1.0.12 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| fstream | < 1.0.12
| 1.0.12
|
| fstream npm | < 1.0.12
| 1.0.12
|
Description
Versions of fstream prior to 1.0.12 are vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system and a file that matches the hardlink will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.
Recommendation
Upgrade to version 1.0.12 or later.
NVD description
fstream before 1.0.12 is vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink, will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free