Kurz gesagt
- CVE-2019-16097 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in github.com/goharbor/harbor, harbor (linuxfoundation).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 22.4%, höher als bei 97.7% aller Schwachstellen.
- Abhilfe: auf 1.9.0-rc1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| github.com/goharbor/harbor Go | ≥ 1.7.0, < 1.9.0-rc1
| 1.9.0-rc1
|
| harbor | = 1.7.0= 1.7.1= 1.7.2= 1.7.3= 1.7.4= 1.7.5= 1.8.0= 1.8.1= 1.8.2= 1.9.0
| No fix yet |
Description
core/api/user.go in Harbor 1.7.0 through 1.8.2 allows non-admin users to create admin accounts via the POST /api/users API. This is fixed in 1.9.0-rc1.
NVD description
core/api/user.go in Harbor 1.7.0 through 1.8.2 allows non-admin users to create admin accounts via the POST /api/users API, when Harbor is setup with DB as authentication backend and allow user to do self-registration. Fixed version: v1.7.6 v1.8.3. v.1.9.0. Workaround without applying the fix: configure Harbor to use non-DB authentication backend such as LDAP.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free