Kurz gesagt
- CVE-2019-19588 ist eine Schwachstelle (HOCH (CVSS 7.5)) in validators, validators (validators project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.5%, höher als bei 73.8% aller Schwachstellen.
- Abhilfe: auf 0.12.6 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| validators PyPI | ≥ 0.12.2, < 0.12.6
| 0.12.6
|
| validators | ≥ 0.12.2, ≤ 0.12.5
| No fix yet |
Description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
NVD description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free