Kurz gesagt
- CVE-2019-5484 ist eine Schwachstelle (HOCH (CVSS 7.5)) in bower (bower), bower.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.6%, höher als bei 85.2% aller Schwachstellen.
- Abhilfe: auf 1.8.8 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| bower | < 1.8.8
| 1.8.8
|
| bower npm | < 1.8.8
| 1.8.8
|
Description
Versions of bower prior to 1.8.8 are affected by an arbitrary file write vulnerability. The vulnerability occurs because bower does not verify that extracted symbolic links do not resolve to targets outside of the extraction root directory.
Recommendation
Update to version 1.8.8 or later
NVD description
Bower before 1.8.8 has a path traversal vulnerability permitting file write in arbitrary locations via install command, which allows attackers to write arbitrary files when a malicious package is extracted.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free