Kurz gesagt
- CVE-2020-11010 ist eine Schwachstelle (HOCH (CVSS 8.8)) in tortoise-orm, tortoise orm (tortoise orm project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.1%, höher als bei 64.6% aller Schwachstellen.
- Abhilfe: auf 0.16.6, 0.15.23 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| tortoise-orm PyPI | ≥ 0.16.0, < 0.16.6< 0.15.23
| 0.16.60.15.23
|
| tortoise orm | ≥ 0.16.0, < 0.16.6< 0.15.23
| 0.16.60.15.23
|
Description
Impact
Various forms of SQL injection has been found, for MySQL and when filtering or doing mass-updates on char/text fields.
SQLite & PostgreSQL was only affected when filtering with contains, starts_with or ends_with filters (and their case-insensitive counterparts)
Patches
Please upgrade to 0.15.23+ or 0.16.6+
For more information
If you have any questions or comments about this advisory:
NVD description
In Tortoise ORM before versions 0.15.23 and 0.16.6, various forms of SQL injection have been found for MySQL and when filtering or doing mass-updates on char/text fields. SQLite & PostgreSQL are only affected when filtering with contains, starts_with, or ends_with filters (and their case-insensitive counterparts).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free