Kurz gesagt
- CVE-2020-15187 ist eine Schwachstelle (MITTEL (CVSS 4.7)) in helm.sh/helm, helm.sh/helm/v3, helm (helm).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.5%, höher als bei 74.5% aller Schwachstellen.
- Abhilfe: auf 2.16.11, 3.3.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| helm.sh/helm Go | ≥ 2.0.0, < 2.16.11
| 2.16.11
|
| helm.sh/helm/v3 Go | ≥ 3.0.0, < 3.3.2
| 3.3.2
|
| helm | ≥ 2.0.0, < 2.16.11≥ 3.0.0, < 3.3.2
| 2.16.113.3.2
|
Description
Impact
During a security audit of Helm's code base, Helm maintainers identified a bug in which a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack.
To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection).
Patches
This issue has been patched in Helm 2.16.11 and Helm 3.3.2.
Workarounds
Make sure to install plugins using a secure connection protocol like SSL.
NVD description
In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack.
To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2.
As a possible workaround make sure to install plugins using a secure connection protocol like SSL.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free