Kurz gesagt
- CVE-2020-15242 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in next.js (vercel), next.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.77%, höher als bei 55.7% aller Schwachstellen.
- Abhilfe: auf 9.5.4 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
| next npm | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
Description
NVD description
Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free