Kurz gesagt
- CVE-2020-26301 ist eine Schwachstelle (KRITISCH (CVSS 10.0)) in ssh2 (ssh2 project), ssh2.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 3.8%, höher als bei 90.1% aller Schwachstellen.
- Abhilfe: auf 1.4.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| ssh2 | < 1.4.0
| 1.4.0
|
| ssh2 npm | < 1.4.0
| 1.4.0
|
Description
ssh2 is client and server modules written in pure JavaScript for node.js. In ssh2 before version 1.4.0 there is a command injection vulnerability. The issue only exists on Windows. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This is fixed in version 1.4.0.
NVD description
ssh2 is client and server modules written in pure JavaScript for node.js. In ssh2 before version 1.4.0 there is a command injection vulnerability. The issue only exists on Windows. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This is fixed in version 1.4.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free