Kurz gesagt
- CVE-2020-4066 ist eine Schwachstelle (HOCH (CVSS 7.2)) in limdu (limdu project), limdu.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.6%, höher als bei 76.3% aller Schwachstellen.
- Abhilfe: auf 0.9.5 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| limdu | < 0.9.5
| 0.9.5
|
| limdu npm | < 0.9.5
| 0.9.5
|
Description
Impact
The trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability.
Patches
Patched in version 0.9.5.
Workarounds
Do not use trainBatch with classifiers that rely on shell execution, such as SVM Perf, SVM Linear or Adaboost
References
No
NVD description
In Limdu before 0.95, the trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. This has been patched in 0.95.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free