Kurz gesagt
- CVE-2020-5284 ist eine Schwachstelle (MITTEL (CVSS 4.3)) in next.js (zeit), next.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 44.8%, höher als bei 98.8% aller Schwachstellen.
- Abhilfe: auf 9.3.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| next.js | < 9.3.2
| 9.3.2
|
| next npm | ≥ 0.9.9, < 9.3.2
| 9.3.2
|
Description
NVD description
Next.js versions before 9.3.2 have a directory traversal vulnerability. Attackers could craft special requests to access files in the dist directory (.next). This does not affect files outside of the dist directory (.next). In general, the dist directory only holds build assets unless your application intentionally stores other assets under this directory. This issue is fixed in version 9.3.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free