Kurz gesagt
- CVE-2021-21317 ist eine Schwachstelle (MITTEL (CVSS 5.3)) in uap-core (uap-core project), uap-core.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.5%, höher als bei 84.9% aller Schwachstellen.
- Abhilfe: auf 0.11.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| uap-core | < 0.11.0
| 0.11.0
|
| uap-core npm | < 0.11.0
| 0.11.0
|
Description
Impact
Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings.
Patches
Please update uap-core to >= v0.11.0
Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
NVD description
uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free