Kurz gesagt
- CVE-2021-27291 ist eine Schwachstelle (HOCH (CVSS 7.5)) in pygments, pygments (pygments).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 3.9%, höher als bei 90.3% aller Schwachstellen.
- Abhilfe: auf 2.7.4 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| pygments PyPI | ≥ 1.1, < 2.7.4
| 2.7.4
|
| pygments | ≥ 1.1, < 2.7.4
| 2.7.4
|
Description
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
NVD description
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free