Kurz gesagt
- CVE-2021-32808 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in ckeditor (ckeditor), application express (oracle), banking party management (oracle).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.2%, höher als bei 68.0% aller Schwachstellen.
- Abhilfe: auf 4.16.2, 21.1.4 oder neuer aktualisieren.
Description
Affected packages
The vulnerability has been discovered in Widget plugin if used alongside Undo feature.
Impact
A potential vulnerability has been discovered in CKEditor 4 Widget package. The vulnerability allowed to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0.
Patches
The problem has been recognized and patched. The fix will be available in version 4.16.2.
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
Acknowledgements
The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.
NVD description
ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free