Kurz gesagt
- CVE-2021-3377 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in ansi up (ansi up project), ansi_up.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 8.0%, höher als bei 94.8% aller Schwachstellen.
- Abhilfe: auf 5.0.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| ansi up | < 5.0.0
| 5.0.0
|
| ansi_up npm | < 5.0.0
| 5.0.0
|
Description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
NVD description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free