Kurz gesagt
- CVE-2021-39187 ist eine Schwachstelle (HOCH (CVSS 7.5)) in parse-server (parseplatform), parse-server.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.8%, höher als bei 78.7% aller Schwachstellen.
- Abhilfe: auf 4.10.3 oder neuer aktualisieren.
Description
Impact
Parse Server crashes when if a query request contains an invalid value for the explain option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch.
Patches
Upgrade to Parse Server 4.10.3
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to version 4.10.3, Parse Server crashes when if a query request contains an invalid value for the `explain` option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch. There is a patch for this issue in version 4.10.3. No workarounds aside from upgrading are known to exist.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free