Red Hat Polkit Out-of-Bounds Read and Write Vulnerability. Actively exploited: CISA added this vulnerability to its Known Exploited Vulnerabilities catalog on 27/06/2022. Patch affected systems as an emergency. It is known to be used in ransomware campaigns.
| Package | Affected versions | Patched versions |
|---|---|---|
| http server | = 12.2.1.3.0= 12.2.1.4.0 | |
| zfs storage appliance kit | = 8.8 | |
| polkit | < 121 | 121 |
| enterprise linux server update services for sap solutions | = 7.6= 7.7 | |
| sinumerik edge | < 3.3.0 | 3.3.0 |
| command center | = 1.0 | |
| starwind virtual san | = v8 | |
| enterprise storage | = 7.0 | |
| linux enterprise high performance computing | = 15.0 | |
| manager proxy | = 4.1 | |
| manager server | = 4.1 |
A local privilege escalation vulnerability was found on polkit's pkexec utility. The pkexec application is a setuid tool designed to allow unprivileged users to run commands as privileged users according predefined policies. The current version of pkexec doesn't handle the calling parameters count correctly and ends trying to execute environment variables as commands. An attacker can leverage this by crafting environment variables in such a way it'll induce pkexec to execute arbitrary code. When successfully executed the attack can cause a local privilege escalation given unprivileged users administrative rights on the target machine.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free