Kurz gesagt
- CVE-2021-41104 ist eine Schwachstelle (HOCH (CVSS 7.5)) in esphome.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.2%, höher als bei 68.7% aller Schwachstellen.
- Abhilfe: auf 2021.9.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| esphome PyPI | < 2021.9.2
| 2021.9.2
|
Description
Impact
Anyone with web_server enabled and HTTP basic auth configured on 2021.9.1 or older
web_server allows OTA update without checking user defined basic auth username & password
Patches
Patch released in 2021.9.2
Workarounds
Disable/remove web_server
NVD description
ESPHome is a system to control the ESP8266/ESP32. Anyone with web_server enabled and HTTP basic auth configured on version 2021.9.1 or older is vulnerable to an issue in which `web_server` allows over-the-air (OTA) updates without checking user defined basic auth username & password. This issue is patched in version 2021.9.2. As a workaround, one may disable or remove `web_server`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free