Kurz gesagt
- CVE-2021-41269 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in com.cronutils:cron-utils, cron-utils (cron-utils project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 4.3%, höher als bei 91.3% aller Schwachstellen.
- Abhilfe: auf 9.1.6 oder neuer aktualisieren.
Description
Impact
A Template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected.
Patches
The issue was patched and a new version was released. Please upgrade to version 9.1.6.
Workarounds
There are no known workarounds up to this moment.
References
A description of the issue is provided in issue 461
For more information
If you have any questions or comments about this advisory:
Open an issue in the cron-utils Github repository
NVD description
cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. In affected versions A template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. The issue was patched and a new version was released. Please upgrade to version 9.1.6. There are no known workarounds known.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free